Archiv für: Januar 2011

17.01.11

Permalink 11:20:50, von kaba E-Mail , 993 Wörter, 1500 Ansichten   German (DE)
Kategorien: Berateralltag

Warum wir Fake-RAIDs hassen sollten und VMware gleich hinterher

Seit letztem Wochenende bin ich von Fake-RAIDs (a.k.a. Motherboard-RAID oder Intel-ICH7/8/9) endgültig geheilt.
Ich hatte nun jahrelang eigentlich recht zufrieden und unbeanstandet ein SATA-II-RAID 10 mit vier Hitachi 300GB-Platten mit 7.200 rpm im Einsatz.Bisheriges System

Wegen ein paar grossen neuen Mandanten, die uns mit umfangreichen Import-Daten "versorgen", nervte aber die Datenbank-Performance und die Analyse der Auslastung mit perfmon hatte gezeigt, dass es eindeutig und nur an der Festplatten-Performance lag. Die war auf 100%, während sich Netzwerkkarte und Prozessor langweilten.

Parallel dazu plante ich ja schon länger, die Linux-VMware (Email-Server usw.), die bisher auf einem eigenen Rechner zusammen mit der DATEV-Kommunikationsserver-Software läuft, auf den Fileserver umzuziehen, d.h. sowohl Fileserver als auch die Linux-VMware auf die schnellere Hardware zu ziehen. RAM wäre genug da (8GB, unser Windows 2003 Std kann eh nur 4GB adressieren), Prozessor-Cores auch.

Schnellere SATA-II-Platten als 7.200 scheint es derzeit nicht zu geben, alles, was mit 10k oder 15k dreht, ist SAS.
Nach gründlicher Analyse von Motherboard-Fähigkeiten und Bedarf sowie Platz und Kühlkapazität im Gehäuse sowie ausgiebigem Studium der VMware-Hardware-Compatibility-List fiel die Wahl auf einen Adaptec 3405 SAS-Controller. Dazu ein passendes FANout-Kabel (8087-> 4x SAS) und vier 15k schnelle 300GB-Platten. Gleich dazu ein Intel Gigabit-LAN-Adapter, damit VMware auch wirklich nur kompatible Hardware findet.

Dann sieht's auch gut aus, wegen der Platzprobleme und meiner nur beschränkten Zeit mal ein etwas ambulanter Aufbau:

Erster Rückschlag war dann schonmal, dass das Kabel gezickt hat und der Controller die Platten nicht gesehen hat. Nach viel Recherchieren und etlichen Anfragen bei Hardware-Händlern hatte sich dann heraus gestellt, dass es nur noch schlechtere Kabel als meines gibt. Ein erneuter Versuch hat dann gezeigt, dass es unglaublich wichtig ist, diesen 8087-Stecker völlig gerade und mit ziemlich Druck einrasten zu lassen.
Dann aber erkennt er auch alles brav:
Boot-Meldung RAID-Adapter

Der Rückschlag nächste kam dann, als ich sowohl mit dem alten als auch dem neuen booten wollte:

Can't find disk multi(0)disk(0)rdisk(1)partition(1)

Was ich auch immer im Motherboard-BIOS oder im RAID-BIOS verstellte, sobald der Adaptec-RAID-Controller drin steckte, konnte ich das alte Betriebssystem nicht mehr booten. Ein direktes Festplatten-Klonen scheidet also aus.

Na, egal, ich wollt' ja eh auf VMware umstellen.

Aaaalso ein Vollbackup auf die externe eSATA-Platte gezogen
und den vorbereiteten VMware ESXi 4.1 Stick gesteckt.

So, und nun mein Fehler:
Das alte SATA-II-RAID nicht komplett von Strom und Daten getrennt, sondern wieder mit beiden RAIDs gebootet.

VMware kommt auch brav hoch, läßt sich konfigurieren.
Beim Aufruf des VSphere-Clients dann allerdings der erste Schock: VMware hat das alte RAID aufgelöst, zwei der vier Platten als "einfache" SATA-Platten erkannt und gleich mit seinem eigenen Dateisystem formatiert. WTF???
Was soll _das_ denn, ein Betriebsystem hat gefälltigst zu fragen, bevor es Partitionen löscht und formatiert!

Entnervt hab ich also den RAID-Controller wieder gezogen und gehofft, dass nicht grad die "falschen" Platten erwischt wurden und der Controller das RAID wieder herstellen kann. Aber oh Wunder, der Controller behauptet, dass RAID wäre intakt!
Boot-Meldung ICH-RAID

Und _natürlich_ ist es nicht intakt, was die Daten drauf angeht, nix bootet da.
GRUMMEL!

Okeeeeh. Boot-CD von Acronis eingelegt, Vollversion von Acronis True Image Enterprise Server mit Universal Restore booten wollen.

"Der Linux-Kernel kann nicht gebootet werden!"

Ebbeh?
Also die "abgesicherte" Version booten. Das alte RAID wird von Acronis offenbar erkannt, die externe Platte auch.
Na gut, also Vollrestore. Dauert ewig, bis ich mal die Partitionen auswählen kann, weil die abgesicherte Version wohl sehr allgemeine Treiber verwendet. Dann startet der Restore und:

"Archiv beschädigt".

PANIK!

Ruhig, Brauner, spielen wir halt das Backup von gestern ein.

"Archiv beschädigt".

VOLLPANIK!
Das Disaster-Backup der (feuer- und wassergeschützten) USB-Platte ist von vor zwei Wochen!

Und von der kann ich auch nix lesen, weil der abgesicherte Modus von Acronis nur ein paar USB-Platten erkennt!

Ok, ich hab' zuviel Koffein intus und es ist zu spät, ich nehm' die externe Platte mit in die Wohnung und sichere erstmal, was drauf ist, auf mein Laptop. Vielleicht ist's ja alles nicht soooo schlimm.

Der Tag danach

Rumkopieren der externen Platte aufs Laptop hatte anstandslos funktioniert. Seltsam. Die Platte ist mittlerweile auch wieder kalt.

Ich hab' mich nun des Nächtens entschieden, dass ich das Vorhaben VMware ESXi aufgebe, hab' einfach kein gutes Gefühl dabei.

Also alle SATA-Platten abgestöpselt, den SATA-RAID-Controller im BIOS auf "Compatible" statt auf "Enhanced" gestellt (unter Verlust der RAID-Funktionalität), die Backupplatte statt an eSATA an USB angestöpselt, den Adaptec eingebaut und die Platten abulant mit Lüfter angeschlossen.

Oh Wunder! Die Acronis-CD bootet anstandslos in der Vollversion.
Das Adaptec-RAID wird voll erkannt (was mich nun gar nicht wundert), die externe Platte auch.
Aha. Mutig geworden, externe Platte doch wieder an eSATA gestöpselt.

Booten, Restore des Vollbackups von vor der ganzen Aktion ausgewählt, Treiber-CD vom Adaptec rein, Treiber auswählen und los.
UND ES IST IN WENIGER ALS EINER STUNDE FEHLERFREI DRAUF!

Booten, RAID-Treiber nochmal einspielen lassen, nochmal booten, ALLES GUT!
alte HDDs ausbauen, neue einbauen, Kabel aufräumen, bessere Lüfter dazu.

Fazit:
Der ganze Scheiss mit nicht-mehr-booten-können-wenn-ein-zweiter-Controller-im-System-steckt, nur die abgesicherte Version des Backup-Programms booten können, Lesefehler von völlig intakten Backupmedien beim Restore, plötzliches "Aufbrechen" des RAID, wenn ein anderes Betriebsystem gebootet wird usw. hat mich endgültig von Billig-RAIDs geheilt!
Das Hardware-RAID ist nicht nur schneller, sondern auch weitestgehend betriebsystemunabhängig, es handelt alles selber und braucht keinerlei Unterstützung durch das Betriebssystem. Das Backup läuft sauber und das Restore geht völlig stressfrei und sehr zügig.

Wenn schon sparen, dann schon ein vollständiges Software-RAID à la Windows Dynamisches Volume oder Linux' md.
Das erkauft man sich aber unter Windows dann wieder mit Problemen:
Subjektiv habe ich den Eindruck, dass ein Software-RAID1 schon _ziemlich_ an der Performance nagt, zumindest beim Schreiben.
Zudem werden die dynamischen Volumes unter Acronis nicht voll unterstützt, man kann keine Acronis Secre Zone drauf anlegen, braucht also für interne Backups immer noch eine weitere Platte.

Die Blog Oase

Die Blog Oase ist ein sehr spezielles Blog! Es vereinigt automatisch alle Einträge der anderen Blogs. Das erlaubt dir, ganz einfach alles zu verfolgen, was in diesem System geschrieben steht.

Januar 2011
Mo Di Mi Do Fr Sa So
 << < Aktuell> >>
          1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30
31            

Suche

Linkblog

Sonstiges

Wer ist online?

  • Gäste: 9

powered by
b2evolution